MT4i/2.1

  • 素敵なツールのご提供ありがとうございます。質問ですが、トップページでは、投稿日時の表示を「日付+時間」「日付のみ」「表示しない」の3つ選択できますが、個別ページでは選択できないのでしょうか? -- 関口? 2006-07-28 09:35:01 (金)
    • 現状、トップページと個別ページで別々の表示形式を選ぶことはできません。 -- 太鉄 2006-09-22 11:45:55 (金)
  • いつも助かっています。カウンターを設置しようと考えているのですがcgiタグは何行目当たりに設置すれば500エラーを引き起こさずに済むでしょうか? -- 名古屋 2006-08-07 04:13:19 (月)
    • 改造のご相談にはお答えしておりません。自力でお願いします。 -- 太鉄 2006-09-25 (月) 17:09:41
  • MovableTypeと同じフォルダに設置して実行をしたところ、ブログを選択するようなメッセージがでました。そこでmt4i.cgi?id=1として実行したところ、サーバーの内部エラーとなります。 -- kossy? 2006-08-09 16:35:29 (水)
    • それだけの情報では何とも。 -- 太鉄 2006-09-25 (月) 17:10:02
  • 初めて使ってみました。設置はできまして、mtのブログの閲覧は出来るのですが、amazonのリンクがエラーとなり、携帯amazonにはつながるのですが、「お探しの商品はみつかりません」と出てしまいます。どうしたらよいでしょうか? -- kim? 2006-08-13 02:05:27 (日)
    • あ、もしやAmazonのURL変わりましたかね?できれば貴方のブログとMT4iのURLか、もしくは変換前のAmazonのURLを教えて頂けませんか? -- 太鉄 2006-08-13 06:17:59 (日)
      • 2.12 にて一部対応。 -- 太鉄 2006-10-11 (水) 21:12:02
  • 特定のカテゴリーを非表示にした場合(0)という表示が残ってしまうようですが、それも表示されないようにしてもらえると嬉しいです… -- KATA? 2006-08-14 10:20:09 (月)
    • どこに残りますか?カテゴリセレクタ?現象確認できません…。 -- 太鉄 2006-09-25 (月) 17:08:53
    • カテゴリセレクタだったのですが当方の勘違いでした。申し訳ありません。 -- KATA? 2006-09-29 (金) 01:48:47
  • コメントの書き込みを出来ないようにしたいんですがどうしたらよいでしょうか? -- こうの? 2006-09-07 04:54:41 (木)
    • コメント投稿機能のON/OFFできます。MT4iManagerにて設定してください。 -- 太鉄 2006-09-25 (月) 17:07:03
  • 水面下で対応済みだったりしそうですが、端末判定を少し改善してみました。SoftBank? 対応など。検討宜しくです。fileFunc.pl-20060926T1000.diff -- drry 2006-09-26 (火) 10:45:00
    • 水面下でも未対応でした。ありがとうございます。近々2.12としてリリースしたいです。 -- 太鉄 2006-09-26 (火) 12:15:28
      • 差分のマージ、どうもありがとうございます。また新たに別の不具合を修正したのですが、ファイルの添付はできなくなってしまいましたね。まぁ、仕方ないですね。 -- drry 2006-10-13 (金) 00:37:55
      • ん、あれ、ファイルの添付は特に禁止していませんよ。できません?別の不具合というのがどれなのか、教えて頂けると助かります。 -- 太鉄 2006-10-13 (金) 09:37:55
      • 前回の差分は添付することができましたが、今はファイルの添付が管理者パスワードで制限されていますね。不具合は、テキストフィルタの日本語ラベルが文字化けしていたので conv_euc_z2h を通すようにしました。他、前回の差分マージで行頭に余計な空白が混入していた部分や、いくつかの正規表現を書き換え、などです。 -- drry 2006-10-13 (金) 12:15:00
      • あ、もしかしたらPukiWikiバージョンアップしたからでしょうかね…。設定で変えられるのかな。 -- 太鉄 2006-10-14 (土) 08:23:43
      • 1.4.6 にて attach プラグインのデフォルト設定が変更され、管理者のみがファイルアップロードできるようになっていました。とりあえず、パスワード無しでアップロードできるようにしました。問題があれば元に戻します。よろしくお願いいたします。 -- 太鉄 2006-10-16 (月) 18:20:29
      • わざわざすいません。差分の内容は上記のとおりです、よろしくお願いします。正規表現のマッチや置換処理の回数を少しでも減らせればと考えたのですが、ちょっと範囲が広いので正規表現の差分は無視してもらっても構いませんです。filemt4i212-20061012T0000.diff.zip -- drry 2006-10-17 (火) 00:04:30
      • ありがとうございます。正規表現については、パイプ(|)を使用すると極端に遅くなるケースがあるので、ベンチマーク等取ってから適用させていただきますね。 -- 太鉄 2006-10-18 (水) 18:49:05
      • あ、確かに、パイプだけでなく、ほかの記述についてもベタ書きよりパフォーマンスが良くないですね…… 無視してください、どうもすいませんでした。 -- drry 2006-10-19 (木) 10:33:16
    • 記事に対しコメントを入力すると、スクリプトエラーが発生します。しかし反映はなされています。何が原因でしょう。なお、その他の動作は特に問題なさそうです。 -- 2006-12-18 (月) 23:02:59
    • V2.13を使用させていただいておりますが、記事に対しコメントを入力すると、スクリプトエラーが発生します。しかし反映はなされています。何が原因でしょう。なお、その他の動作は特に問題なさそうです。 -- hori? 2006-12-18 (月) 23:06:26
  • MT3.33を使っています。mt公開ディレクトリにmt4iをアップしています。mt4imgr.cgiにはアクセスできるのにmt4i.cgiにアクセスしようとするとThe script did not produce proper HTTP headers. Please see the error log to see the detail of the errors. Depending on the server configuration, you can also run thisscript under CGIWrap debugging. Usually, either rename or linkthe script temporarily to a file which ends with .cgidextension, or add a AddHandler cgi-script-debug .cgiline to your .htaccess file.などというエラーが出てしまいます。以前は大丈夫だったのに…。どうしてでしょうか? -- naja? 2006-10-06 (金) 12:24:54
    • 昨日コメントさせていただいたnajaです。追加コメントです。XREAでMT3.33です。MT4i/2.0だとエラーが出ずに使えることがわかりました。MT4i/2.1だとだめですが…どうしてでしょうか?やはり携帯で閲覧できるって非常に便利なのでなんとかならないかなと思っているのですが…。 -- naja? 2006-10-07 (土) 12:22:28
      • Ver2.11のファイル全てをテキストモードでアップしてmt4i.cgi,mt4imgr,cgiのパーミッションを700にしたらOKでした。XREAでも使えます。自己解決(苦笑) -- naja? 2006-10-08 (日) 10:22:32
  • タイトルをクリックすると勝手に他のサイトへ飛びます…、記事がみれません。ちなみにタイトルは<a href="どこか">どこか</a>のタグを使っています。他のサイトに飛ばさないで、記事を見るように出来るにはどうすればよいですか? -- sora? 2006-10-15 (日) 11:18:54
    • すみません、質問の意味がさっぱり分からないです。んー、chtmltrans を通したくないということですか?であれば、<a>タグの title 属性に MT4i Maneger で設定した文字列(デフォルトでは"携帯対応")を含めてください。 -- 太鉄 2006-10-15 (日) 13:28:54
      • 設置したMT4iのメインページから1〜10のタイトルをクリックすると他のサイトに飛びます、そのそのせいでエントリーの内容がみれません。他のサイトに飛ばないでエントリーの内容をみれるにはどうすればよいですか?ちなみMovable Typeでエントリーを投稿するときタイトルはいつも<a href="どこか">どこか</a>を使ってます。また、わからなかったらどこの辺りがわからないかおしえてください。 -- sora? 2006-10-15 (日) 17:39:18
      • ああ、そういうことですか。たぶん理解できました。えーと、それはもうしょうがないですね。申し訳ありませんが、MT4i ではエントリのタイトルが<a>タグで囲まれることを想定しませんので、そういう動きになるのが当然です。「他のサイトに飛ばないでエントリーの内容を見るにはどうすれば良いですか?」という質問には、「<a>タグで囲むのをやめてください」と回答するしかないです。あとは MT4i 側で、記事を一覧表示する際にタイトルに含まれる<a>タグを取り除くようにするかですか、しかしわざわざタイトルをそういう形にしてるってことは、必要だからやってるんですよね?取り除いちゃって大丈夫でしょうか? -- 太鉄 2006-10-15 (日) 20:38:10
      • 取り除くことできるますけど…、不便さがします(すみませんorz なんとかできないんでmt4.cgiのとこの525行目の$data .= "<a href=\"$href\">$rowid.</a><a href=\"$href\">$title</a>$created_on";にして1〜10みたいな数字のとこをクリックして、エントリーの内容がみれるようにしました。これはどう思いますか?タイトルそのままクリックするできるようにするほうが便利だと思いますけどねぇ… -- sora? 2006-10-15 (日) 22:50:43
      • エントリタイトルのリンクを残すのであれば、現状ではそれしか方法が無いでしょう。もしくは<a href"外部url">タイトル</a>→<a href"エントリurl">このエントリを読む</a>みたいにするか。いずれにしろ、現状こちらでは対応できませんので、soraさんの責任の下、修正してください。 -- 太鉄 2006-10-19 (木) 11:26:01
  • まだクロスサイトスクリプティングの脆弱性が残ってるみたいです。$imgがエスケープされてないので、img=%22%3E%3Cscript%3Ewindow.alert(document.cookie)%3C/script%3E%3Cとかできちゃいます。2.12のソースを参照しました。 -- hagi? 2006-10-20 (金) 15:54:02
    • お知らせありがとうございます。そうか、そこは見落としていたようです。チェックして対策版をリリースします。 -- 太鉄 2006-10-20 (金) 20:47:19
      • 2.13 で対応しました。 -- 太鉄 2006-10-25 (水) 02:28:18
  • MT4iVer2.xを使わせて頂いてます。数日前よりwmlproxy.google.comが消滅?したのか、外部リンクがDNSが見付からない状態になっているようです。自分はgoogle.co.jp提供の携帯変換処理へ変更して対応しましたが、とりあえずお知らせしておきます -- minagi? 2006-10-25 (水) 00:44:47
    • うおっとホントですね。お知らせありがとうございます。US ではサービスやめたのでしょうかね。次のバージョンでは別のサービスへの対応も検討したいと思います。 -- 太鉄 2006-10-25 (水) 02:27:12
    • mlproxy.google.comが消えている件で困っています。「google.co.jp提供の携帯変換処理へ変更して修正」と書かれていらっしゃいますが、具体的にはこれはどう変更すればよいか教えていただけませんか? -- hiro? 2006-10-27 (金) 01:03:38
      • 保証は全くありませんがそれでもよければ・・・。2.13ベースMT4i.cgi本体、3372行からのURL置換の@を%に変更(s/¥//¥@2F/g;をs/¥//¥%2F/g;)。以下2行も同様。変換用URLをgoogle.co.jpへ変更(my $chtmltransurl = 'http://www.google.co.jp/gwt/n?mrestrict=chtml&source=m&output=chtml&hl=ja&u=';)。不要なパラメータを削除($url = $chtmltransurl . $url;「. "/c=0"」を取ります)。以上です。分かりづらい書き方をしてしまいましたが、他のバージョンでも同様の修正でいけると思います。 -- minagi? 2006-10-27 (金) 05:38:10
  • お答えいただきありがとうございます。ピンチでしたのでご返事感謝しております。早速試してみましたが、書き換えてアップしてみたところwmlproxy.google.comへのリンクが変わりません。「再起動」的なオペレーションが必要なのでしょうか?初歩的質問で申し訳ありません。 -- hiro? 2006-10-27 (金) 11:26:53
    • 通常の入れ替え作業と同じで再起動の必要はありません。ローカルのPC等で編集、保存したソースをサーバーにアップロードするだけです。なお上の説明だと分かりづらいかと思い「http://www.koruri.com/dielectric/archives/200610/27000584.html」へまとめましたので、宜しければ参照してください。 -- minagi? 2006-10-27 (金) 13:41:03
      • minagi様ありがとうございました!!うまく行きました!!すばらしいです! 最初wmlproxy.google.comから直らなかったのは、mt4iのファイル名を替えて置いているのをすっかり忘れていました。お恥ずかしいです。 -- hiro? 2006-10-28 (土) 00:57:26
  • とても小さなことですが、コメント投稿者がURLを入れている場合に、携帯から見てもそのURLへアクセスできるようにするにはどうしたらよいですか?ちょっと聞かれたので宜しくお願いします! -- ハナコ? 2006-10-30 (月) 13:51:54
    • 現状、できません。 -- 太鉄 2006-11-10 (金) 10:41:08
  • いつのまにかHTML::Entitiesが必要になってしまったのですね、、。うちのサーバーにはこれが入ってないっす。プロバイダのサーバーなんでインストールもできません、、。(ToT) -- SARU? 2006-11-10 (金) 02:40:39
    • HTML::Entitiesなくても動くように検討してみます(もちろんセキュリティは下がります) -- 太鉄 2006-11-10 (金) 10:37:51
  • はじめまして!全く素人なんですが・・・MTバージョン3.32を使いMT4i213をディレクトリにアップしパーミッションを705に変更していますが、mt4imgr.cgiにアクセスするとnot foundになってしまい困っています!エディターで編集して保存する際にデフォルトのECUのままだとアップした時に文字化けしているようです!エディター編集時に保存する文字コードは何が相応しいのでしょうか?また、MTのバージョンとMT4iのバージョンの互換性などもあるのでしたら私の使用してるMT 3.32と相性の良いMT4iのバージョンを教えて下さい -- taka 2006-11-10 (金) 09:58:14
    • 500 Internal Server Error ならまだ分かりますが、404 Not Found となると根本的になにか勘違いされている可能性が高いと思います。ファイルをアップロードした場所と、アクセスしている URL を良く見比べてみてください。 -- 太鉄 2006-11-10 (金) 10:40:11
      • 太鉄様、早速の返信ありがとうございます!やはり何度見てもアップロードの場所も間違っておりませんし、アクセスしてるURLにも間違いはありません・・・ちなみに使っているサーバーはロリポップです。転送ソフトはftpです。転送の際に自動で文字コードが変換されてしまう事で404エラーになってしまうという事はあり得ますか?素人なので変な質問ですみません。ちなみにここで公開するのはどうかと思うのですが・・・エラーが出てしまうURLは http://rakupapa3.boy.jp/ds/cgi/mt/mt4imgr.cgi です。 -- taka 2006-11-10 (金) 10:57:16
      • 転送の際に自動で文字コードが変換されてしまう事で404エラーになってしまうという事はあり得ません。File Not Found はその言葉の通り「ファイルが見つかりません」ということですから、そこにファイルがないか、あるとしたらサーバが壊れているかのどちらかです。 -- 太鉄 2006-11-10 (金) 11:13:45
      • ご親切にありがとうございました。再度、色々とチャレンジしてみます。 -- taka 2006-11-10 (金) 11:22:34
      • 実際の URL は "/ds" を除いて一つ上の http://rakupapa3.boy.jp/cgi/mt/mt4imgr.cgi ですね。アクセスすると表示上は「File Not Found!」となっていますが、実際には 500 Internal Server Error です。 -- drry 2006-11-10 (金) 11:52:10
      • ん、「実際には 500 Internal Server Error」というのはどうして分かりました? -- 太鉄 2006-11-10 (金) 12:07:58
      • これって実際は500エラーなんですか?ということはMT自体の問題という事でしょうか? -- taka 2006-11-10 (金) 12:55:02
      • ちなみに私はこのドメインで複数のMTブログを運営しておりますが今までに500エラーは出たことありません・・・やはりロリポップサーバーの問題なのかもしれませんね・・・ -- taka 2006-11-10 (金) 13:16:36
      • 昨日はお世話になりました!色々試行錯誤した結果mt4imgr.cgiにはアクセス出来る様になり管理画面へログイン出来る様になったのですが、本体であるmt4i.cgiの方にアクセスするとnot foundになってしまいます(汗)URLは間違っておりませんし、cgiファイルもきちんとアップロードされています。この件で不具合が起きるという事例はありませんでしょうか? -- taka 2006-11-11 (土) 14:31:00
      • 申し訳ございませんが事例はありません。mt4imgr.cgi にアクセスできるようになったのは、どのような処置を施したからですか?今回の mt4i.cgi 同様の現象のようなので、同様の処置を施せば解決できませんでしょうか? -- 太鉄 2006-11-11 (土) 18:02:47
      • 気付いたんですが、ロリポップってエラーページをカスタマイズできるようになりましたよね?もしかして設定のミスかなんかで、500 Internal Server Error 時にも 404 File Not Found のページが表示されるようになってしまっていませんか? -- 太鉄 2006-11-11 (土) 18:05:38
      • 今確認しましたが、やはり実際は 500 Internal Server Error が返っているようです。 -- 太鉄 2006-11-11 (土) 18:08:30
      • お世話になります!mt4i213をDLしてエディターで編集後(文字コードはEUCのまま)、普通にアップロードして属性を705に変更してアクセスしたらmt4imgr.cgiにアクセス出来る様になりました!特にエラーページの設定などはいじっていませんが…実際は500エラーという事であれば何処かに問題があるという事ですね!500エラーが出た場合の対処方法が解らないのですが…お手数でなければ教えて頂けないでしょうか? -- taka 2006-11-11 (土) 18:24:58
      • エディターで編集後(文字コードはEUCのまま)、普通にアップロードして属性を705に変更してアクセスしてください。それで動かないのであれば、ホームディレクトリの設定見直してください。MT4i/2.0/インストールの手順通り設置して頂いてますか?ちなみにこの Wiki が設置されているこのサーバもロリポップですし、MT4i のテストもほぼこのサーバで行っていますので、動かないということは基本的にはあり得ないと思います。必ず何かしら設定、設置方法等に問題があるはずです。 -- 太鉄 2006-11-11 (土) 18:33:59
      • ありがとうございます!(嬉)出来ました!アクセスOKです!昨日から色々と本当にありがとうございました!設定画面の必須設定画面という所のホームディレクトリと所を記載していたのが原因だったようです!特に何も記載せずに保存し、アクセスしたらOKでした!本当にお手数をお掛け致しました!太鉄様!感謝!感謝!です! -- taka 2006-11-11 (土) 18:43:42
  • 太鉄様 MT 3.2-ja-2 MT4i を使用させて頂いております。素敵なツール提供ありがとうございます。今回は「あいのり」機能の使い方がいまいち分からないのでコメントさせて頂きました。「あいのり」機能を使用すれば同じMT内で違うブログを読み込む事が出来るという事でしょうか?現在、各ブログ毎に大カテゴリ分けをしグローバルmenuを作成してmain menuを作っています。MT4iでもグローバルmenuを作りたいのですが、「あいのり」機能を使用する事で実装する事が出来るのでしょうか?また、何か他のやり方がありましたら教えて頂けませんでしょうか。初心者質問で恐縮ですが、どなたかお分かりになる方がいらっしゃいましたらご教授下さいませ。宜しくお願いします。 -- mune? 2006-11-16 (木) 15:00:48
    • すみません、現状では、複数のブログにまたがるような使い方は想定してません。あいのり機能(Mobile Link Discovery)というのは、エントリ本文中に張られた<a>タグによるリンク先にモバイル用のページが準備されている場合にそちらを表示するための機能です。 -- 太鉄 2006-11-18 (土) 14:27:46
      • >太鉄様 なるほど、そういう意味でしたか。返答ありがとうございました。自力でグローバルmenuを作ってみたいと思います。 -- mune? 2006-11-18 (土) 19:02:34
  • はじめまして。MT4i使わせていただいています。imgタグを<img alt="荒野" src="<$MTBlogURL$>img/photo/<$MTArchiveDate? format="%Y/%m/%d/%m%d-"$>001.jpg" />のようにEvalTemplate?プラグインを使用して記述しているのですが、MTタグが変換されず、画像が表示できない状況です。MTタグを変換できるように、又はなにか良い方法はないでしょうか? -- JApe? 2006-11-16 (木) 22:35:57
    • すみません、EvalTemplate?プラグインというのは使用したことはありませんし、今後も対応する予定はございません。 -- 太鉄 2006-11-18 (土) 14:28:51
  • お疲れ様です!サブカテゴリに関してですが、親カテゴリを選択すると、サブカテゴリのエントリーも全部表示されるようにするには、どのようにしたら良いでしょうか。(MTタグでいう<MTEntriesWithSubCategories?>のような感じです)既出でしたらすみません; -- Utsuki? 2006-11-21 (火) 10:22:03
    • 他の方のサイトで、一つのエントリーに、サブカテゴリと親カテゴリの2つを設定して、mt4iでも親カテゴリ選択でサブカテゴリ表示を可能にしてらっしゃいました。この方法しかないのでしょうか; -- Utsuki? 2006-11-21 (火) 10:32:28
      • 今のところそれしか無いです。将来的にはなんとかしたいと思いますが、いつ対応できるかはちょっとお約束できません。すみません。 -- 太鉄 2006-11-29 (水) 18:16:00
  • はじめまして。MT4i導入してみたのですが、質問があります。当方、画像(PNG)が多いブログなのですが、<画像:20061126071433>というようにリンクされて表示される画像とそのまま表示されてしまう画像があります。また、携帯からだとそのまま表示される画像が表示されないので困っています。(PC上からだと見える)なにか設定などあるのでしょうか?サーバーはsakuraインターネットのスタンダードプランです。http://maple.kowappa.com/cgi/MT4i/mt4i.cgi -- 虎!? 2006-12-05 (火) 11:04:15
    • 見させていただきましたが、確かになんかおかしい動きをしてますね。設定とかの問題じゃないと思います。ご迷惑をおかけいたしますが、調査にお時間をいただけますでしょうか。 -- 太鉄 2006-12-09 (土) 11:13:33
      • 原因判明。<img>タグ内に改行が含まれている為、MT4iでうまくパースできていないようです。将来的には改行が含まれていても動作するよう対応するべきだと思っていますが、早急に問題を解決されたいのであれば、<img>タグ内の改行を取り去ってみてください。あと、携帯で画像が表示されないのは、御使用のキャリアでサポートされていない形式の画像(PNGとかGIFとか)だたらではないでしょうか。 -- 太鉄 2006-12-09 (土) 15:13:42
  • お疲れさまです。要望なのですが、コメントやトラックバックの表示を管理者のみ表示することは出来ませんでしょうか。 -- 2006-12-06 (水) 16:50:19
    • それはどういった理由で必要になりますか?それが必要なシチュエーションというのをいまいち想像できないのですが…。 -- 太鉄 2006-12-09 (土) 11:14:58
  • 携帯で閲覧できるようになってとても助かってます。ありがとうございます。他ドメインのリンク先に移動する時に、「別のサイトへジャンプしようとしています」というページが表示されますが、このページをなくすことはできますでしょうか?このページの下の方にある、「下記URLであれば表示できるかもしれません」のURLがいつも間違っているので、ユーザーに無駄なパケ代を使わせることになります。また、このページ自体表示しない方が良いのではないかと思っています。すみませんが、宜しくお願いします。 -- Anonymous? 2006-12-10 (日) 18:50:50
    • 上記質問、新規Wikiページを立てられていたのでこちらへ移動。まじめにレスすると、間違っているのではなくリンク先が消滅してしまった為(このコメント欄の以前のコメントを辿って頂けば分かるはず)、対策版をリリースするべく2.2β1を昨日リリースしています。よろしくお願いいたします。 -- 太鉄 2006-12-10 (日) 18:54:26
  • カテゴリの順番を入れ替えるプラグイン(CategoryLabelEx?やcutfirstchar)などを入れている場合、カテゴリ選択のプルダウンには全て表示されてしまいますが、PC版と同様な表示に変えることは可能でしょうか? -- WARA? 2006-12-12 (火) 18:50:39
    • 現状不可能と思われます(思われます、というのは、私がその Plugin を知らないからです)。 -- 太鉄 2006-12-13 (水) 01:27:27
  • 初めまして。MT4i 2.13を使用させて頂いております。管理者権限にて新規エントリを行う際、500エラー(premature end of script headers)が発生してしまいます。ただ、下書きで投稿した場合、問題なく投稿完了します。公開の状態で投稿すると500エラーが発生してしまいます。何が原因か考えられますでしょうか?お忙しい所、申し訳ありませんが、よろしくお願い致します。 -- にの? 2006-12-14 (木) 15:49:45
    • おそらくタイムアウトしているものと思われます。新規エントリ投稿時にはDB更新、関連HTMLファイル(再)構築、トラックバックPingの送信等、様々な処理が裏で走ります(下書き投稿の場合はDB更新のみであっという間です)。MT本体の方では、処理単位で動的にリロードしているのでタイムアウトが発生しない場合でも、携帯電話ではJavaScript?が使えない(一部使える機種もある?)のでMT4iでは対応しておらず、タイムアウトになる確立が高いです。MT本体でも発生しているようならなおのことです。色々と対策は考えておりますが、良い案は未だ思いつきません。確実なのは、もっと速いサーバに引っ越して頂くことですが…。それでも、Ping送信先のレスポンスによってはタイムアウトする可能性はあります。 -- 太鉄 2006-12-14 (木) 16:08:17
      • 素早いご回答有難うございました。試しにping送信先を全て削除し、投稿してみた所、正常に投稿ができました。太鉄さんの仰る通りタイムアウトが原因の様です。 -- にの? 2006-12-14 (木) 16:28:24
      • やはりそうですか。この件については過去本当にたくさんの方からお問い合わせいただいており、また、私自身も何度も遭遇しているのですが、なかなか打開策が見つからないでいます。 -- 太鉄 2006-12-15 (金) 01:09:53
  • 度々、申し訳ありません。MT3.3-jaを利用しております。MTの管理画面より指定日公開でエントリすると、その指定日時にてPC側は公開されるのですが、MT4iの方では、即時公開されてしまいます。この件に関し、何か対応策はあるのでしょうか?もし、あるのであれば、ご教示下さい。よろしくお願い致します。 -- にの? 2006-12-21 (木) 11:46:06
    • この件、勘違いでした。管理者モードの状態で確認してしまいました。通常モードでは公開されていませんでした。早とちりでした。申し訳ありません。 -- にの? 2006-12-21 (木) 17:07:25
  • はじめまして。たった今設置をさせて頂きました。携帯で閲覧すると<画像:×××>というように、リンク表示されますが、これを最初から画像で表示させることはできますか? -- しゃりすけ? 2006-12-23 (土) 17:27:30
    • できません。すみません。 -- 太鉄 2006-12-25 (月) 20:20:23
  • 懸案事項になっているPocket IEやMobile OPERAの対応として、文字化けに半角スペースの変換を行なわないように改造してみたところ、現状ではうまくいっています。その他にもW-ZERO3に最適化するような変更を行ないましたのでもしよければ次のURLを参考にしてください。 http://www.yancha.org/2007/01/12/wzero3mt4i/ -- YANCHA! 2007-01-12 (金) 17:31:55
    • Version 2.2では是非反映させて頂きたいと思います。ありがとうございます。 -- 太鉄 2007-01-17 (水) 11:16:35
  • MT本体でカテゴリの順番を変更するプラグインを導入しています。そのためプラグインが繁栄されないMT4iではカテゴリ名が「001ニュース」「002日記」など番号が出てしまい困ってます。カテゴリ名を前から指定文字数でカットするようにできないでしょうか? -- RYO? 2007-01-15 (月) 10:47:07
    • んー、できなくは無いですが…。検討します。 -- 太鉄 2007-01-17 (水) 11:20:26
    • こちらのページが参考になりませんか?(っていうか、導入されているプラグインもこちらのもの?)→http://www.h-fj.com/blog/archives/2005/12/15-091528.php なお、カスタマイズはご自身の責任において行ってくださるようお願いいたします。 -- 太鉄 2007-01-19 (金) 10:11:07
  • mt3.31、mt4i2.13使いです。あいのり機能が巧く作動していない様で自ブログ内のリンクに一旦ページを噛む様な感じになっています。以前のバージョンではON/OFFの切り替えで、ONにしておけば自動で自ブログのmt4iページにリンクされてたと思うのですが、今回からはどの様にすれば同じ動作をしてくれますか? -- ? 2007-01-17 (水) 15:48:20
    • ごめんなさい、現在ではそういう仕様になっています。リンクが複数含まれている場合に、LWPによるページ取得に結構時間がかかって、表示が重たくなっている為の対策です。本文表示時にはリンク先の取得を行わないで、リンクがクリックされたときに初めて取得、MLD(あいのり機能)のアドレスの有無を見ています。MLDのアドレスがあった場合には、そのまま自動的に遷移しても良いかもしれませんね。検討します。 -- 太鉄 2007-01-17 (水) 16:09:20

添付ファイル: filemt4i212-20061012T0000.diff.zip 3471件 [詳細] fileFunc.pl-20060926T1000.diff 5150件 [詳細] fileFunc.pl.diff 1718件 [詳細]

トップ   編集 凍結解除 差分 バックアップ 添付 複製 名前変更 リロード   新規 一覧 単語検索 最終更新   ヘルプ   最終更新のRSS
Last-modified: 2007-04-10 (火) 17:43:54 (3881d)